Resolved
Payments Account Detail page is currently unaccessible

Started
May 25, 2022 at 3:35 PM
Status
Resolved after about 2 hours
Affected
Payments

Impact

Operational
  • Resolved
    May 25, 2022 at 5:14 PM

    Functionality has returned to normal. We are marking this incident as resolved, we will be implementing more fixes in the near future to prevent a similar incident from occurring. We thank you for bearing with us during this incident.

  • Monitoring
    May 25, 2022 at 4:48 PM

    We have implemented a fix and have seen error rates returning to normal. We will continue to monitor to ensure the issue is fully resolved.

  • Identified
    May 25, 2022 at 4:06 PM

    We have identified the issue and are working on a fix for both the Account Details page and the Invoice page failing.

    Disabling the ACH/Bank Transfer option as a payment method will allow the invoice to be paid by our other methods of payment while we work on the fix. We appreciate the patience with this incident.

    We will update shortly with more information.

  • Investigating
    May 25, 2022 at 3:43 PM

    We are seeing an inability to pay invoices with ACH/Bank Transfer as an option for customers to use. We are upgrading this to a major outage. Our team is working on alleviating this issue as quickly as possible.

    We will continue to provide updates as we learn more.

  • Investigating
    May 25, 2022 at 3:35 PM

    We are currently investigating an incident where Podium Payment users are unable to access the Account Details page. We will be able to provide an update soon.