Resolved
Card Reader Issues

Started
May 11, 2022 at 6:56 PM
Status
Resolved after 22 minutes
Affected
Payments

Impact

Operational
  • Resolved
    May 11, 2022 at 7:18 PM

    We have implemented a fix and are continuing to monitor to ensure the issue has been resolved.

  • Investigating
    May 11, 2022 at 6:56 PM

    We’re currently investigating intermittent issues with our card readers. We are investigating and will provide an update soon.